AF不稳定?是用户配置异常,还是软件存在异常?不得其姐

Yan Lv2发表于 2017-9-10 01:01

本帖最后由 Yan 于 2017-9-10 01:12 编辑

前言:
      今年1月份开始使用深信服NGAF,设备购买回来时AF版本为7.1。供应商帮忙部署上线后就出现各种小问题,由于网络环境简单,没有在设备处启用过多限制功能,用的最多的是设备的路由功能,主要是路由负载方面。先说下现在的网络环境:
     

拓扑

拓扑
       一、带宽线路总共3条:eth3 、eth4为拨号线路 ;eth5为专线线路。
       二、策略路由: 1、源地址策略路由:172.16.1.1 至 172.16.1.20 所有流量走eth5;
                                 2、多线路负载路由:所有网络流量 通过轮询的方式走eth3 、eth4、eth5。
问题描述:

       故障1:初次部署上线后,网络总出现上网缓慢的情况,线路带宽并未占满,联系400工程师,检查也没检查出什么问题,后来重启设备后,逐渐正常。
       故障2:6月份更换了外网线路,主要在设备接口页面更换接口地址,更改配置后,在接下来的几天内,连续出现了好多次断网现象,每次断网时间持续5分钟左右,联系400售后,售后说设备是代理商维保,联系代理商查看问题,配置什么都正常,就是没检查出故障所在,后来我自己在业务空闲时,把设备重启,使用几天,断网的现象消失了。
       故障3:8月末因业务需要,访问国际网络的机会增加,特开通了国际专线业务。了解到7.3版本支持地区路由选路,所以从AF7.1版本升级到了最新的AF7.3。
                   升级到7.3版本后,首先出现路由不稳定现象,172.16.1.1至172.16.1.20的主机根据策略路由的配置,应该所有流量都从eth5出外网,却出现了数据出口异常的问题。这部分主机走固定的出口是因为,需要使用一些比如ssh 、telnet、mysql远程连接到云服务器上,在云服务器的防火墙限定,只有eth5接口的地址才能连接。异常表现在,某台主机突然无法通过ssh、telnet、mysql连接远程云主机,但策略路由范围内其他主机均正常,tracert主机的路由跟踪,出口正常,不知道哪里抽了,就是连接不上。出现这样的情况,主要是云服务器检查到进入的数据地址跟云服务器防火墙的配置不一致,数据被拒绝,导致无法连接。
                   起初出现上面路由不稳定的情况时,没有在意。到本周一(9月4号)上班后,同事反应上网慢的情况,那么问题来了,登陆到防火墙后,发现eth3口没有数据流动,eth4口只有在eth5口数据跑满的情况下,才有数据流动。心想是负载均衡路由出现问题。联系400工程师,帮忙查看,一番排查,配置没什么异常,策略路由调动调动调动,eth3口依然没有数据走,检查配置,多线路策略路由放在最上面,没反应,检查其他配置没问题。突然不知道为什么数据流动正常了,但上面提到的出口异常问题还没检查出来,现在仍然在观察中。。。。。。。。。。。
        故障4:在今晚更改了eth5口的IP地址,更改了静态路由对于eth5口条目的下一条地址。增加了策略路由(国际路由),除中国地区以外,其他地区走eth5口出去。测试了下,貌似没有生效。
                    于是tracert路由,发现数据还是从旧IP的网关出去了。登陆到web界面检查接口地址,发现接口地址已经更改好的。找了个国外的IP在web界面里的进行路由测试,发现刚刚添加的国际路由策略路由没有生效。主机打开国外的网站也无法打开,不知道是配置没有生效,还是运营商问题。。。。下面附设备路由表,和tracert的路由情况。。。。(设备重启过还几次了)
5784259b420ed1f2a2.png
7425559b419debfaa6.png
8899359b4189091760.png
乱七八糟的写了一堆,不知道写了些什么,对于上面故障3存在的问题,目前400工程师还在跟进,让我继续观察。希望深信服能够引起重视,帮忙彻底解决,找出问题所在。。。。。。。。。。。。。。。。。。。

解决该疑问,预计可以帮助到 10449 人!

回帖即可获得
2S豆
×
参与回帖,有更多机会领取S豆哦 立即回帖>>
,被楼主采纳即奖励20S豆+10分钟内回帖奖励10S豆 [已过期] ,了解更多S豆奖励信息

完善手机号和公司名称,让服务更省心更便捷!立即完善

adds Lv15发表于 2017-9-10 16:11
  
如果400也查不同问题,就不应该是策略问题。
建议,先找个测试设备,把策略配置上,如果测试设备一切正常,怀疑设备有问题。
leyshan Lv6发表于 2017-9-10 18:23
  
找400要一个好的工程师看一看吧,没有描述的那么神奇!不要找深信服要“姐”,要要“妹子”就有解了
zhangxin Lv8发表于 2017-9-10 20:21
  
硬件型号?带宽多少
qinpeng Lv14发表于 2017-9-10 22:29
  
400售后应该是没有问题的,策略的网络配置应该也是正常。针对楼主提到每次故障时重启设备都恢复正常。这个有可能是设备问题,联系先跟当地供应商协调个设备进行测试观察,你的故障问题我们帮你进行督促,请楼主放心
Sangfor闪电回_小丸子 发表于 2017-9-11 17:03
  
您好 麻烦在“个人资料”里面备注下单位/公司名称和联系方式,这边安排工程师联系您远程协助
谢谢
破晓残阳 Lv3发表于 2017-9-14 09:50
  
不知你们单位使用网络人数如何。。之前也有碰到过类似的问题,不过是出现在路由器上的 也是用一段时间上网慢 重启设备恢复    原因是因为nat会话表无法正常释放tcp连接
×
有话想说?点这里!
可评论、可发帖

等我来答:

换一批

本版版主

107
35
6

发帖

粉丝

关注

本版达人

新手74996...

本周建议达人

小豆子

本周分享达人

WANGJL

本周提问达人