|
问题现象: 腾讯会议,腾讯文档,迅雷等无法正常登录,登录二维码无法加载,提示网络异常;微信发图片时不时发送失败等。
背景: 客户需要使用双栈认证场景,开启了IPV4密码认证和IPV6密码认证,但是平时只认证IPV4,并没有认证IPV6导致IPV6相关丢包,同时客户开启了SSL证书分发,且包含了所有IPV4和V6地址,重定向了ipv6流量,导致部分应用使用异常。 问题原因: 1、 双栈场景ipv6地址未认证导致丢包
2.、ssl根证书分发重定向了ipv6流量,导致应用异常
解决方法: 1、双栈场景ipv6地址未认证导致丢包。 如果开启IPV6认证,ipv6地址也要手动访问下地址做一下认证。即访问1.1.1.2 认证ipv4上线后,再访问 IPV6认证地址http://[1::2]/不会再弹密码框,反过来也是一样。 用户需要的操作->访问http://[1::2]/和 http://1.1.1.2各一次,密码只用输一次。 (具体认证地址可以在系统配置 的重定向和代理高级配置中查看和配置) 双栈场景需要后台开启双栈: (1)修改配置,cat /ac/etc/config/fw/dual_stack.ini,将enable改成1即可启用 (2)重启认证和NGINX服务
daemonrestart ac-auth-mon
/etc/init.d/nginx restart 此操作对已经认证的用户不受影响。
2、ssl根证书分发重定向了ipv6流量,导致应用异常
去除IPV6的证书分发地址,ipv4去分发可以覆盖全部设备。
结论: 按客户要求将IPV6认证关闭,SSL证书分发去除IPV6地址后应用恢复正常。 |